D-Link DGS-3620-28TC

Introduction

External design

Hardware

Firmware upgrade

Web-interface

Command line

Testing

Conclusion

Introduction

Our test lab has been really interested in reviewing D-Link DGS-3620-28TC switch because it possesses the VLAN Translation feature. We already saw this function in network equipment by other vendors, but up until now we have not managed to make it work. DGS-3620-28TC switch has successfully coped with this task. However, first things first.

External design

D-Link DGS-3620-28TC routing switch comes in a 1U metal case that has a plastic front panel and is meant to be rack-mounted. The device has dimensions of 441x310x44 mm (not considering the brackets). Brackets that are used to rack-mount the device and rubber legs for desk-mounting are included in the box.

Upper and bottom panels are not remarkable at all. On the side panels there is a ventilation grate used for device cooling. Unfortunately, the air jet direction cannot be changed and the air circulates only from one side panel to the other. It's worth noticing that the bracket may be fastened to DGS-3620-28TC both near the front and rear panel.

On the rear side of the device there are a power socket and cable inlet (covered by a safety plate), which is used to get connected to a standby power supply unit.

The front panel has 20 copper Gigabit Ethernet ports (1 to 20), four combo ports (21 to 24) used for connection of copper or optical network, and four SFP+ ports used to get connected to 10GE optical networks. Apart from it, on the main panel there are an SD card slot, socket for external sensor connection, LEDs that indicate status of the device and all of its ports, and console and control interfaces.

Now let's have a look at the insides of the case.

Hardware

Hardware platform of DGS-3620-28TC switch consists of four cards: two main cards and two support ones. The support cards are charged with PSU and LED operation functions.

This small card performs control module functions and has main elements located on both sides.

The device system is powered by a single core MIPS Broadcom BCM53003B3KPBG CPU that operates within the frequency of 600 MHz. The block diagram of this CPU is presented below.

Two Spansion S29GL512P11TFI01 modules, with the size of 64 Mbytes each, act as the device flash memory, making the total system flash memory size 128 Mbytes. Two DDR2 Winbond W971GG6JB-25 modules, with the size of 128 Mbytes each, act as the device RAM, making the total RAM size 256 Mbytes.

The following Broadcom chips are used on the large card for changeover reasons: BCM54680B0KFBG, BCM54640B0KFBG, BCM8747BKFBG, and BCM56334B0KFSBG. Broadcom BCM5461SA1KPFG module maintains operation of the MGMT port. Operation with SD cards is sustained by Realtek RTS5159 chip.

That is where we bring the review of the device hardware to a conclusion and pass on to examining capabilities of its software component.

Firmware upgrade

Firmware upgrade may be carried out either using the command line or the device web-interface. At first, let's review the firmware upgrade process via the command line interface. One needs to download the firmware file from the vendor's website and upload it to the TFTP server beforehand.

The user can learn about the current firmware version using show switch command.

DGS-3620-28TC:admin#sho swi
Command: show switch
Device Type : DGS-3620-28TC Gigabit Ethernet Switch
MAC Address : 84-C9-B2-1F-BE-00
IP Address : 10.90.90.90 (Manual)
VLAN Name : default
Subnet Mask : 255.0.0.0
Default Gateway : 0.0.0.0
Boot PROM Version : Build 1.00.012
Firmware Version : Build 1.00.035
Hardware Version : A1
Firmware Type : EI
Serial Number : PVXF1B8000113
System Name :
System Location :
System Uptime : 0 days, 1 hours, 22 minutes, 1 seconds
System Contact :
Spanning Tree : Disabled
GVRP : Disabled
IGMP Snooping : Disabled
MLD Snooping : Disabled
RIP : Disabled
RIPng : Disabled
DVMRP : Disabled
PIM : Disabled
PIM6 : Disabled
OSPF : Disabled
OSPFv3 : Disabled
BGP : Disabled
VLAN Trunk : Disabled
Telnet : Enabled (TCP 23)
Web : Enabled (TCP 80)
SNMP : Disabled
SSL Status : Disabled
SSH Status : Disabled
802.1X : Disabled
Jumbo Frame : Off
CLI Paging : Enabled
MAC Notification : Disabled
Port Mirror : Disabled
SNTP : Disabled
DHCP Relay : Disabled
DNSR Status : Disabled
VRRP : Disabled
HOL Prevention State : Enabled
Syslog Global State : Disabled
Single IP Management : Disabled
Password Encryption Status : Disabled
DNS Resolver : Disabled

The first thing there's to do is to upload the firmware file to the switch.

DGS-3620-28TC:admin#download firmware_fromTFTP 10.90.90.92 src_file new.had dest_file c:/new.had
Command: download firmware_fromTFTP 10.90.90.92 src_file new.had dest_file c:/new.had
Connecting to server................... Done.
Download firmware...................... Done. Do not power off!
Please wait, programming flash......... Done.
Success.

Then one needs to specify that this very firmware should be used after the reboot and finally reload the device.

DGS-3620-28TC:admin#dir
Command: dir
Directory of /c:
Idx Info Attr Size Update Time Name
--- ------- ---- -------- ------------------- ----------------
1 RUN(b) -rw- 7182308 2000/01/01 02:06:39 new.had
2 RUN(*) -rw- 7182308 2000/01/01 02:01:38 runtime.had
3 d--- 0 2000/01/01 00:00:12 system
126002 KB total (111882 KB free)
(*) -with boot up info (b) -with backup info
DGS-3620-28TC:admin#config firmware image c:/new.had boot_up
Command: config firmware image c:/new.had boot_up
Success.
DGS-3620-28TC:admin#show boot_file
Command: show boot_file
Bootup Firmware : /c:/new.had
Bootup Configuration : /c:/config.cfg
DGS-3620-28TC:admin#reboot
Command: reboot
Are you sure you want to proceed with the system reboot?(y/n)

The administrator can make sure that the firmware upgrade has been executed successfully using the same command, show switch (the command output was partially shortened).

DGS-3620-28TC:admin#show switch
Command: show switch
Device Type : DGS-3620-28TC Gigabit Ethernet Switch
Boot PROM Version : Build 1.00.012
Firmware Version : Build 1.00.038

Also, it's worth noticing that the firmware upgrade process may be carried not for just one device, but also for a whole group of devices. If this is the case, one needs to specify IDs of those devices that are planned to be upgraded.

DGS-3620-28TC:admin#download firmware_fromTFTP sr src_file new.had unit ?
Command: download firmware_fromTFTP sr src_file new.had unit
Next possible completions:
<unit_id>

The user can do the same by using the web-interface and referring to Download Firmware sub-menu, Tools menu.

Once the file has been uploaded to the switch, the user will need to save the current settings and reboot the device.

One can make sure that the firmware upgrade has been executed successfully on the device home page.

That is where we bring review of D-Link DGS-3620-28TC firmware upgrade procedure to a conclusion and pass on to examining its software capabilities.

Web-interface

Apart from the above-mentioned VLAN Translation feature, D-Link DGS-3620-28TC also possesses a wide array of various capabilities, which we are going to briefly review now. To log on an administrator must specify the login and password. These two fields must be blank if the latest firmware versions are used.

Upon successful authentication the administrator will find him/herself on the home page of the device where s/he can learn brief information about the device and supported protocols.

System Configuration menu item allows the administrator to manage time settings, alter the user database, and specify stacking and log parameters. Also, one can group physical ports over here.

We would like to mention Port Configuration sub-group that allows managing physical operation of the device network interfaces. If DDM (Digital Diagnostic Monitoring) is supported by the optical SFP modules, the administrator will need to use the items of the same-named sub-group to gain access to this feature.

D-Link DGS-3620-28TC doesn't support PoE (Power over Ethernet), but if stacking is switched on, the applicable sub-group appears in the menu. That happens due to the possibility to add a switch to the stack with PoE support.

Management group includes management access parameters. D-Link DGS-3620-28TC supports both the outband and inband management. Also, this group has Power Saving sub-group that is used to alter power saving settings.

Using VLAN sub-group, L2 Features group, the administrator can use tags, ports, MAC or IP-addresses, or network layer protocols to assign the client device to this or that virtual network. Using this group one also can manage settings of information distribution protocol for GVRP virtual networks, super virtual networks, and voice and private VLANs. Actually, the assignment to voice VLANs can also be established using LLDP sub-group.

Operation parameters of QinQ technology and spanning tree protocol are located in QinQ and Spanning Tree sub-groups, the same group. VID translation—a VID that is transferred through the trunk port is changed for another VID—is a really nice feature of D-Link DGS-3620-28TC.

Aggregation of physical ports into one logical port is performed in Link Aggregation group, the same-named menu item. LACP is used for the aggregate interface support.

MAC-address table and its operation parameters are available in FDB sub-group.

L2 Multicast Control and Multicast Filtering sub-groups are used to manage multicasting.

ERPS Settings subgroup is used to establish ring topologies in Ethernet without involvement of STP, but using a more promising solution—ERPS (Ethernet Ring Protection Switching (ITU-T G.8032))—that secures the network operation recovering time at 50 ms or lower.

D-Link DGS-3620-28TC switch allows network administrators to get servers connected to it; the load between them will be then balanced via NLB (Network Load Balancing) technology. Applicable settings can be applied in NLB FDB Settings sub-group.

End-to-end transparent clock information can be learnt using PTP. These settings are located in the same-named sub-group.

Static routing management is carried out using the first four sub-groups in L3 Features group. Static routes for multicasting are specified in Static Multicast Route Settings sub-group.

The L3 switch under review supports static multicast policies. The corresponding settings are located in Policy Route Settings sub-group, the same group.

Routes received via various dynamic routing protocols may be assigned preferences that need to be set up using the administrative distance, which is changed using Route Preference Settings sub-group, L3 Features group.

Load balance settings between the same (according to OSPF) routes may be altered in ECMP Algorithm Settings sub-group.

Redistribution of routes between various routing protocols is carried out using Route Redistribution sub-group.

Management of 6to4, ISATAP, and GRE tunnels is performed using IP Tunnel sub-group.

Access to operation parameters of OSPF, RIP, and BGP dynamic routing protocols is gained using same-named sub-groups. Configuration of OSPF authentication is performed using MD5 Settings sub-group.

Management of multicast traffic routing is carried out using IGMP Static Group Settings sub-group and elements in IP Multicast Routing Protocol sub-group.

Usage of the right topology where all key elements are doubled is the most sensible method of network construction. This can be carried out using VRRP, whose settings are located in the same-named sub-group.

By using IP Route Filter sub-group the administrator can specify routing information distribution rules for certain sub-networks.

Using URPF Settings sub-group one can switch on spoofing protection feature for certain physical ports (URPF – Unicast Reverse Path Forwarding).

Management of 802.1p, parameters of traffic control, and all other settings associated with quality of service are located in QoS group.

Management of access lists is carried out using sub-groups in ACL group. Filtering the traffic destined to the switch itself comes to be a nice feature.

Security group is charged with 802.1X protocol operation, RADIUS authentication, binding of IP and MAC-addresses to a certain port, MAC-based access control, HTTP-based user authentication, DoS-attack prevention, loop detection, and trusted host settings.

Apart from its key functions—switching and routing—D-Link DGS-3620-28TC can also carry out a wide array of support functions by substituting for a range of low-loaded servers within the network. Among these functions are ability to act as a DHCP server and relay for the IPv4 and IPv6, DNS relay, and SNTP server. In order to access the above-mentioned features one needs to use Network Application group. Also, the administrator can view the contents of the built-in flash memory and carry out several activities associated with it. It's worth noticing that UDP Helper sub-group in UDP group allows the user to manage forwarding of certain UDP datagrams to a single-purpose server.

Cable diagnostics settings are available in OAM group. Also, one can alter parameters associated with 802.1ag standard support over here.

Sub-groups in Monitoring group display the CPU, RAM, and flash memory utilisation ratio. One can also review the physical port usage ratio over here. Statistical data on port operation are located in Statistics sub-group.

D-Link DGS-3620-28TC switch supports SPAN and RSPAN sessions. The corresponding settings are located in Mirror sub-group.

In order to manage sFlow the administrator needs to use the same-named sub-group

Network connectiveness can be checked using Ping sub-group in Trace Route group.

The administrator can check the temperature inside the case, FAN speed, or diagnose any other incidents using Peripheral sub-group.

That is where we bring the review of the switch web-interface to a conclusion and pass on to examining the capabilities of its command line interface.

Command line

One can access the device command line through Telnet and SSH protocols, which must be permitted to use in the corresponding groups in the web-interface.

We will not review all capabilities of the switch command line in detail, but we would like to point out that the vendor believes this adjustment method to be the most flexible. Almost all commands may be divided into key groups: clearing or reset commands – clear, configuration commands – config, creation and deletion of virtual objects – create and delete, debugging – debug, enabling and disabling – enable and disable, and reviewing – show. We present the full command list in a separate file.

Thus, we were really interested in show utilization dram command that displays utilisation of RAM. We can see from its output that DGS-3620-28TC switch cannot be used for interaction with BGP full-view, which accounts for about half a million records today.

DGS-3620-28TC:admin#show utilization dram
Command: show utilization dram
DRAM utilization :
Total DRAM : 262144 KB
Used DRAM : 253073 KB
Utilization : 96 %

The user can learn who is in control of the switch at the moment by using show session command.

DGS-3620-28TC:admin#show session
Command: show session
ID Live Time From Level User
--- ------------ --------------------------------------- ----- ---------------
8 08:47:34.070 Serial Port login Anonymous
24 00:21:29.120 172.17.35.36 admin Anonymous
Total Entries: 2

One needs to use show fdb command to review the bridge table. In our case the table was all blank.

DGS-3620-28TC:admin#sho fdb
Command: show fdb
Unicast MAC Address Aging Time = 300
VID VLAN Name MAC Address Port Type Status
---- -------------------------------- ----------------- ----- ------- -------
1 default 84-C9-B2-1F-BE-00 CPU Self Forward
Total Entries: 1

Information about currently functioning services is located in show switch command output.

DGS-3620-28TC:admin#show switch
Command: show switch
Device Type : DGS-3620-28TC Gigabit Ethernet Switch
MAC Address : 84-C9-B2-1F-BE-00
IP Address : 10.90.90.90 (Manual)
VLAN Name : default
Subnet Mask : 255.0.0.0
Default Gateway : 0.0.0.0
Boot PROM Version : Build 1.00.016
Firmware Version : Build 2.50.017
Hardware Version : A1
Firmware Type : EI
Serial Number : PVXF1B8000113
System Name :
System Location :
System Uptime : 5 days, 8 hours, 50 minutes, 28 seconds
System Contact :
Spanning Tree : Enabled
GVRP : Disabled
IGMP Snooping : Disabled
MLD Snooping : Disabled
RIP : Disabled
RIPng : Disabled
DVMRP : Disabled
PIM : Disabled
PIM6 : Disabled
OSPF : Disabled
OSPFv3 : Disabled
BGP : Disabled
VLAN Trunk : Disabled
Telnet : Enabled (TCP 23)
Web : Enabled (TCP 80)
SNMP : Disabled
SSL Status : Disabled
SSH Status : Enabled
802.1X : Disabled
Jumbo Frame : Off
CLI Paging : Enabled
MAC Notification : Disabled
Port Mirror : Disabled
SNTP : Disabled
DHCP Relay : Disabled
DNSR Status : Disabled
VRRP : Disabled
HOL Prevention State : Enabled
Syslog Global State : Disabled
Single IP Management : Disabled
Password Encryption Status : Disabled
DNS Resolver : Disabled

Apart from the specified commands, there is also an array of other system calls that are not directly associated with this or that command group. This is, for example, how one can check network connectiveness using ping or traceroute commands.

DGS-3620-28TC:admin#ping 8.8.8.8
Command: ping 8.8.8.8
Reply from 8.8.8.8, time=10ms
Reply from 8.8.8.8, time=10ms
Reply from 8.8.8.8, time=10ms
Reply from 8.8.8.8, time=10ms
Ping Statistics for 8.8.8.8
Packets: Sent =4, Received =4, Lost =0

In the testing chapter we will be drawing a chart to check the performance of VLAN translation feature using the device web-interface. The similar thing can also be done using the command line.

DGS-3620-28TC:admin#create vlan_translation ports 8 replace cvid 3 svid 2 priority 0
Command: create vlan_translation ports 8 replace cvid 3 svid 2 priority 0
Success.
DGS-3620-28TC:admin#show vlan_translation
Command: show vlan_translation
Port CVID SPVID Action Priority
----- -------- -------- ------- ---------
8 3 2 Replace 0
14 3 2 Replace -
Total Entries: 2

The user can save the settings using save command.

DGS-3620-28TC:admin#save
Command: save
Saving all configurations to NV-RAM.......... Done.

That's where we proceed to completion of the brief review of D-Link DGS-3620-28TC command line capabilities and pass on to testing it.

Testing

Conventionally, we begin our testing section with estimating the booting time of the device, which is a time interval starting with the moment when the power is on until the first echo reply is received through ICMP. D-Link DGS-3620-28TC boots in 35 seconds, which is a decent result.

The second test is a security scanning procedure, which has been carried out using Positive Technologies XSpider 7.7 (Demo build 3100) utility. The scanning has been carried out from a host connected to the control interface. On the whole, there were two open ports discovered, and they are TCP-23 (Telnet) and TCP-443 (HTTP SSL). The most interesting data are presented below.

Usually, modern switches do not experience any problems with frame transfer at the wire speed, and therefore we decided not to test the device performance when switching and routing are on. Instead of this we have measured a delay that DGS-3620-28TC causes upon switching and routing for frames with size of 100, 400, 1400, and 1518 bytes. These tests were carried out under different interface load with the connection speed of 1 Gbps. The primary specifications of the test stand we used are presented below.

Component PC Notebook
Motherboard ASUS Maximus V Extreme ASUS M60J
CPU Intel Core i7 3770K 3.5 GHz Intel Core i7 720QM 1.6 GHz
RAM DDR3 PC3-10700 SEC 32 Gbytes DDR3 PC3-10700 SEC 16 Gbytes
NIC Intel Gigabit CT Desktop Adapter Atheros AR8131
OS Windows 2008 R2 x64 Rus Windows 7 x64 SP1 Rus

The switching and routing delays that D-Link DGS-3620-28TC switch causes can be observed on the diagrams below.

Both images show that delays upon transfer of 400 byte frames are much higher that those for frames of other sizes. Unfortunately, we cannot give a sensible explanation of the result we received, but even the delays for 400 byte frames are within normal limits. An average delay that the L3 switch under review causes is 4 µS, which, as we think, is a pretty decent result for such devices. When network interfaces—ones that were used to transfer the test frames—were loaded more heavily, the delay saw a slight increase but was still within reasonable limits. The results we received are better that the ones for Cisco Catalyst 3750G switches we got before.

For us one of the newest and most interesting features is VLAN translation, which is a part of QinQ technology. The idea behind VLAN translation is that it helps users to change one VID value to another in tagged frames. In other words, it allows you to define assignment of a certain frame—received via the trunk port—to VLAN. To test operability of this function we drew up a chart that is presented below. We would like to mention right away that it could also have been done via setting up different Native VLAN values in the opposite trunk port sides. However, this kind of a scheme would only work for a single virtual network, whilst VLAN translation allows the user to change these values for several VIDs at the same time.

There was another thing we wanted to implement, and that was the deployment of STP on all three switches, which, as we think, is necessary for fully-featured network operation. Since 'the firsts STP standard' is long outdated, the only reasonable thing we could do was to use MST instead. Ports got blocked upon forwarding through DGS-3620-28TC BPDU Cisco PVST+. It happened because Cisco Catalyst switches viewed BPDU of one virtual network inside of tagged frames of another virtual network. We used the only STP instance—MST0—so as not to make the construction more difficult. All virtual networks on switches were added to this instance. We carried out the below-mentioned settings adjustment on Cisco Catalyst switches.

left(config)#spanning-tree mode mst
left(config)#spanning-tree mst configuration
left(config-mst)#instance 0 vlan 1-4094

On the left Cisco Catalyst switch we created VLAN 2 and SVI with the following parameters.

interface Vlan2
ip address 192.168.1.1 255.255.255.252
end

On the right switch we established VLAN 3 with a corresponding virtual interface.

interface Vlan3
ip address 192.168.1.2 255.255.255.252
end

A trunk has been created between C3750G switch (on the left) and DGS-3620-28TC that we used to allowed virtual network 2 from Cisco Catalyst direction. We did the same for C2960 switch (on the right), but the allowed VLAN was 3.

interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
load-interval 30
end

Now let's have a look at DGS-3620-28TC settings. VLAN 2 and 3 were allowed on trunk ports.

We also needed to specify the port role, outer TPID, and switch on QinQ.

Now let's manage the VID translation.

Also, we should not forget about Spanning Tree settings.

The chart we made proved a success since ICMP echo requests have been transferred between SVI interfaces of Cisco Catalyst switches.

right#sho ip int bri | i up
Vlan3 192.168.1.2 YES manual up up
GigabitEthernet0/1 unassigned YES unset up up
right#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/9 ms
right#

We also checked operation of the Spanning Tree protocol by increasing the preference value for edge switches, leaving DGS-3620-28TC settings as they were. An increase in preference usually lowers a probability for a switch to become the root device in STP tree. Therefore, D-Link DGS-3620-28TC was supposed to be chosen as the root switch. The readers can make sure of it by viewing the status of Catalyst switches for applicable virtual networks.

left#sho spanning-tree vlan 2
MST0
Spanning tree enabled protocol mstp
Root ID Priority 32768
Address 84c9.b21f.be00
Cost 20000
Port 1 (GigabitEthernet1/0/1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 61440 (priority 61440 sys-id-ext 0)
Address 04fe.7fc5.9780
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/0/1 Root FWD 20000 128.1 P2p Bound(RSTP)

right#sho spanning-tree vlan 3
MST0
Spanning tree enabled protocol mstp
Root ID Priority 32768
Address 84c9.b21f.be00
Cost 20000
Port 25 (GigabitEthernet0/1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 61440 (priority 61440 sys-id-ext 0)
Address 88f0.77dc.1880
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/1 Root FWD 20000 128.25 P2p Bound(RSTP)

Since the equipment set-up and testing of the functionality in question took us really a lot of time to get done with, we decided to provide the readers with full configuration files for the left and right switches, as well as for D-Link DGS-3620-28TC.

D-Link DGS-3620-28TC switch allows limiting the speed of user traffic that is transferred through a certain port (QoS-Bandwidth Control-Bandwidth Control Settings), and therefore we decided to compare the stipulated values with the real user traffic transfer speeds. The diagram below shows that both axes are of logarithmic scale.

We also decided to test operation of a function associated with aggregation of physical channels into a logical one. We used Cisco Catalyst 2960 as the second switch to carry out this test. The testing procedure was carried using virtual network 2 that has been created on both switches. We created VLAN2 interface with 192.168.2.1/24 IP-address (Management-IP Interface-Interface Settings) on DGS-3620-28TC switch, while on Catalyst 2960 there was SVI interface created—also in the virtual network 2—that was assigned 192.168.2.2/24 IP-address.

Ports 21 and 22 of DGS-3620-28TC switch were added to trunks with allowed VLAN2 (L2 Features-VLAN-802.1Q VLAN Settings). The same was done on Catalyst 2960 switch for Fa0/21 and Fa0/22 ports.

We created Port-Channel 1, which includes ports 21 and 22, using Port Trunking Settings and LACP Port Settings sub-groups in L2 Features-Link Aggregation group. Balancing is carried out according to the sender and recipient's IP-addresses.

We performed the same kind of adjustment for Catalyst 2960. The listing presented below contains only those commands that were directly associated with the test.

port-channel load-balance src-dst-ip
vlan 2
name up_vlan
interface Port-channel1
switchport trunk allowed vlan 2
switchport mode trunk
interface FastEthernet0/21
switchport trunk allowed vlan 2
switchport mode trunk
load-interval 30
channel-protocol lacp
channel-group 1 mode active
spanning-tree portfast trunk
interface FastEthernet0/22
switchport trunk allowed vlan 2
switchport mode trunk
load-interval 30
channel-protocol lacp
channel-group 1 mode active
spanning-tree portfast trunk
interface Vlan2
ip address 192.168.2.2 255.255.255.0
load-interval 30

Successful creation of a logical channel is displayed in show etherchannel summary command output, which we used on Cisco Catalyst 2960 switch.

2960#sho etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Fa0/21(P) Fa0/22(P)

One also can make sure that the set up channel is operating well via dispatching ICMP echo requests, which can be sent from any of the switches. An example of this kind of dispatch carried out via DGS-3620-28TC switch is presented below (Monitoring-Ping-Ping Test).

The LLDP MED feature operation test has been chosen as the final testing procedure for D-Link DGS-3620-28TC switch. This feature allows the user to get an IP phone connected to one of the switch ports the way so that the phone belongs to one virtual network, while the PC connected through this phone assigns to another network. If this is the case, the IP phone will act as the bridge. In order to carry out this test we used Avaya one-X and Deskphone 9620L and 9650 phones. The switch port where one gets the phone connected to may be set up as a usual virtual network access port for PC. Apart from it, the user should put in the following commands.

enable lldp
config lldp_med ports 11 med_transmit_capabilities all state enable
enable voice_vlan vlanid 3
config voice_vlan ports 11 state enable

We would like to point out that we connected the phone to the 11th port, while VLAN 3 was used as a voice virtual network. In other words, upon repetition of the above-mentioned commands one will need to change the port and virtual network numbers for those that are currently used in the real network.

The user can check whether the phone has been successfully connected using show voice_vlan lldp_med voice_device command, the output of which is presented below.

DGS-3620-28TC:admin#show voice_vlan lldp_med voice_device
Command: show voice_vlan lldp_med voice_device
Index : 1
Local Port : 11
Chassis ID : 172.16.99.249
Port ID Subtype : MAC Address
Port ID : 3C-B1-5B-4B-9C-C7
Create Time : 7/25/2013 06:38:37
Remain Time : 98 Seconds
Total Entries : 1

The same data can be also obtained using L2 Features-VLAN-Voice VLAN-Voice VLAN LLDP-MED Voice Device group in the web-interface.

The administrator can make sure that the equipment works properly by making a test call over the phone to diagnose whether the other part of the PC network, connected to the phone, is available for access.

That's where we draw the testing chapter of D-Link DGS-3620-28TC switch to a close and move on to summing it all up.

Conclusion

In general, we are pleased with the GE L3 D-Link DGS-3620-28TC switch we reviewed. Its capabilities are well enough for efficient operation within the framework of access to and aggregation of large networks, as well as of network cores of small to mid companies. The command line interface, compared with the web interface, though not cisco-like, possesses a richer scope of capabilities. At first we were a bit baffled by this, but as we kept on working we got familiar with the system syntax.

The strength areas of DGS-3620-28TC are presented below.

  • A wide array of functional capabilities
  • Support of IPv6
  • Ability to perform DHCP server functions with support of several additional features
  • Support of SNMPv3
  • Ability of both inband and outband management
  • Support of VLAN translation feature
  • Availability of LLDP MED
  • Support of virtual stacking

Unfortunately, we cannot help to mention some of its drawbacks.

  • Slightly sluggish web-interface
  • Challenging command line interface.

As of when this article was being written, the average price for D-Link DGS-3620-28TC in Moscow online shops was 75,000 roubles.

The author and editorial staff are grateful to Anticisco project for assisting us with carrying out testing procedures.

Add comment


Security code
Refresh

Comments   

0 #1 D-Link DGS-3620-28TCmaryelleneagar 2017-02-12 05:52
Hello, I think your website might be having browser compatibility issues.
When I look at your blog in Firefox, it looks fine but when opening in Internet Explorer, it has some overlapping.
I just wanted to give you a quick heads up! Other then that, wonderful blog!
Quote | Report to administrator
Found a typo? Please select it and press Ctrl + Enter.