Description

The aim of this lab is to get the students familiar with hybrid devices that perform functions of the second and third layers of OSI model. Common examples of such devices are L3 switches that forward not only Ethernet frames but IP packets, too. Installing an interface card of L2 or L3 switch into the router, helping the device perform both switching and routing functions, is yet another example of such use. It's worth mentioning that the router can perform frame switching even without a special-purpose switch module.

In this lab we will review examples of configuring such devices. The used topologies will be quite simple and one will need only a limited set of equipment necessary for demonstration of this or that feature. The lab is performed using a GNS3 emulator.

Auxiliary switching module

The first part of this lab will be dedicated to configuring Cisco NM-16ESW expansion card which is installed in Cisco 3725 router (ESW1 device). A virtual L2 switch, powered by IOU (IOS on Unix), will be used too.

The first thing one should begin with is fitting Cisco 3725 router with NM-16ESW L2 module with 16 Fast Ethernet ports. Please ask your teacher to provide you IOS for the router.

The listing presented below contains the output of diagnostic commands performed on the router.

ESW1#sho ver
Cisco IOS Software, 3700 Software (C3725-ADVENTERPRISEK9-M), Version 12.4(15)T14, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by Cisco Systems, Inc.
Compiled Tue 17-Aug-10 12:08 by prod_rel_team
ROM: ROMMON Emulation Microcode
ROM: 3700 Software (C3725-ADVENTERPRISEK9-M), Version 12.4(15)T14, RELEASE SOFTWARE (fc2)
ESW1 uptime is 39 minutes
System returned to ROM by unknown reload cause - suspect boot_data[BOOT_COUNT] 0x0, BOOT_COUNT 0, BOOTDATA 19
System image file is "tftp://255.255.255.255/unknown"
This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.
A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
If you require further assistance please contact us by sending email to
This email address is being protected from spambots. You need JavaScript enabled to view it..
Cisco 3725 (R7000) processor (revision 0.1) with 124928K/6144K bytes of memory.
Processor board ID FTX0945W0MY
R7000 CPU at 240MHz, Implementation 39, Rev 2.1, 256KB L2, 512KB L3 Cache
18 FastEthernet interfaces
DRAM configuration is 64 bits wide with parity enabled.
55K bytes of NVRAM.
1024K bytes of ATA System CompactFlash (Read/Write)
Configuration register is 0x2102
ESW1#sho inven
ESW1#sho inventory
NAME: "3725 chassis", DESCR: "3725 chassis"
PID:                   , VID: 0.1, SN: FTX0945W0MY
NAME: "16 Port 10BaseT/100BaseTX EtherSwitch on Slot 1", DESCR: "16 Port 10BaseT/100BaseTX EtherSwitch"
PID: NM-16ESW=         , VID: 1.0, SN: 00000000000
ESW1#

Let's create two virtual networks on router 3725: VLAN 10 (left) and VLAN 20 (right).

ESW1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
ESW1(config)#vla 10
ESW1(config-vlan)#nam left
ESW1(config-vlan)#vla 20
ESW1(config-vlan)#nam rigth
ESW1(config-vlan)#^Z
ESW1#sho vlan-switch bri
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/1, Fa1/2, Fa1/3
 Fa1/4, Fa1/5, Fa1/6, Fa1/7
 Fa1/8, Fa1/9, Fa1/10, Fa1/11
 Fa1/12, Fa1/13, Fa1/14, Fa1/15
10   left                             active
20   rigth                            active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
ESW1#

Let's set Fa1/0 interface as the access port in VLAN 10.

ESW1#sho run int fa1/0
Building configuration...
Current configuration : 84 bytes
!
interface FastEthernet1/0
 switchport access vlan 10
 duplex full
 speed 100
end

Then let's set Fa1/1 interface as a trunk, allowing only one virtual network, VLAN20. Apart from the user virtual networks the IOS requires availability of five auxiliary networks: 1, 1002-1005.

ESW1#sho run int fa1/1
Building configuration...
Current configuration : 126 bytes
!
interface FastEthernet1/1
 switchport trunk allowed vlan 1,20,1002-1005
 switchport mode trunk
 duplex full
 speed 100
end
ESW1#sho int trunk
Port      Mode         Encapsulation  Status        Native vlan
Fa1/1     on           802.1q         trunking      1
Port      Vlans allowed on trunk
Fa1/1     1,20,1002-1005
Port      Vlans allowed and active in management domain
Fa1/1     1,20
Port      Vlans in spanning tree forwarding state and not pruned
Fa1/1     1,20

Let's configure the third-level virtual interfaces that belong to the used virtual networks and enable routing for IP.

ESW1#sho run int vla 10
Building configuration...
Current configuration : 63 bytes
!
interface Vlan10
 ip address 192.168.10.1 255.255.255.0
end
ESW1#sho run int vla 20
Building configuration...
Current configuration : 63 bytes
!
interface Vlan20
 ip address 192.168.20.1 255.255.255.0
end
ESW1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
ESW1(config)#ip routing
ESW1(config)#exi
ESW1#sho ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C    192.168.10.0/24 is directly connected, Vlan10
C    192.168.20.0/24 is directly connected, Vlan20

Let's make these necessary configurations on IOU1 switch.

IOU1#sho run int e0/0
Building configuration...
Current configuration : 124 bytes
!
interface Ethernet0/0
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 20
 switchport mode trunk
end
IOU1#sho run int e0/1
Building configuration...
Current configuration : 93 bytes
!
interface Ethernet0/1
 switchport access vlan 20
 switchport mode access
 duplex auto
end
IOU1#sho vla bri
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Et0/2, Et0/3, Et1/0, Et1/1
 Et1/2, Et1/3, Et2/0, Et2/1
 Et2/2, Et2/3, Et3/0, Et3/1
 Et3/2, Et3/3
20   right                            active    Et0/1
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
IOU1#sho int tru
Port        Mode             Encapsulation  Status        Native vlan
Et0/0       on               802.1q         trunking      1
Port        Vlans allowed on trunk
Et0/0       20
Port        Vlans allowed and active in management domain
Et0/0       20
Port        Vlans in spanning tree forwarding state and not pruned
Et0/0       20
IOU1#

It's worth noticing that the auxiliary switching card doesn't allow only for data forwarding but also for participating in building the STP tree. The listing below shows STP status for VLAN 20 virtual network on router 3725.

ESW1#sho spanning-tree vlan 20
 VLAN20 is executing the ieee compatible Spanning Tree protocol
 Bridge Identifier has priority 32768, address c201.3488.0002
 Configured hello time 2, max age 20, forward delay 15
 We are the root of the spanning tree
 Topology change flag not set, detected flag not set
 Number of topology changes 2 last change occurred 00:25:08 ago
 from FastEthernet1/1
 Times:  hold 1, topology change 35, notification 2
 hello 2, max age 20, forward delay 15
 Timers: hello 1, topology change 0, notification 0, aging 300
 Port 42 (FastEthernet1/1) of VLAN20 is forwarding
 Port path cost 19, Port priority 128, Port Identifier 128.42.
 Designated root has priority 32768, address c201.3488.0002
 Designated bridge has priority 32768, address c201.3488.0002
 Designated port id is 128.42, designated path cost 0
 Timers: message age 0, forward delay 0, hold 0
 Number of transitions to forwarding state: 1
 BPDU: sent 1289, received 2

Review the output of the respective diagnostic command performed on IOU1 switch.

IOU1#sho spanning-tree vlan 20
VLAN0020
 Spanning tree enabled protocol ieee
 Root ID    Priority    32768
 Address     c201.3488.0002
 Cost        100
 Port        1 (Ethernet0/0)
 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
 Bridge ID  Priority    32788  (priority 32768 sys-id-ext 20)
 Address     aabb.cc00.0100
 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
 Aging Time  300 sec
Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Root FWD 100       128.1    Shr
Et0/1               Desg FWD 100       128.2    Shr

Let's assign IP parameters of PC1 host.

PC1> sho ip
NAME        : PC1[1]
IP/MASK     : 192.168.10.2/24
GATEWAY     : 192.168.10.1
DNS         :
MAC         : 00:50:79:66:68:00
LPORT       : 10000
RHOST:PORT  : 192.168.56.1:10001
MTU:        : 1500

And then do exactly the same for PC2 host.

PC2> sho ip
NAME        : PC2[1]
IP/MASK     : 192.168.20.2/24
GATEWAY     : 192.168.20.1
DNS         :
MAC         : 00:50:79:66:68:01
LPORT       : 10006
RHOST:PORT  : 192.168.56.101:10001
MTU:        : 1500

Let's make sure that there is connectivity between PC1 and PC2 hosts.

PC1> ping 192.168.20.2
84 bytes from 192.168.20.2 icmp_seq=1 ttl=63 time=14.502 ms
84 bytes from 192.168.20.2 icmp_seq=2 ttl=63 time=20.003 ms
84 bytes from 192.168.20.2 icmp_seq=3 ttl=63 time=20.503 ms
84 bytes from 192.168.20.2 icmp_seq=4 ttl=63 time=20.502 ms
84 bytes from 192.168.20.2 icmp_seq=5 ttl=63 time=11.002 ms
PC1> trace 192.168.20.2
trace to 192.168.20.2, 8 hops max, press Ctrl+C to stop
 1   192.168.10.1   10.002 ms  9.001 ms  9.001 ms
 2   *192.168.20.2   21.003 ms (ICMP type:3, code:3, Destination port unreachable)

Now let's connect PC3 host to a port of the switch module that operates in the L3 mode.

ESW1#sho run int fa1/2
Building configuration...
Current configuration : 111 bytes
!
interface FastEthernet1/2
 no switchport
 ip address 192.168.30.1 255.255.255.0
 duplex full
 speed 100
end

PC3 host settings are standard.

PC3> sho ip
NAME        : PC3[1]
IP/MASK     : 192.168.30.2/24
GATEWAY     : 192.168.30.1
DNS         :
MAC         : 00:50:79:66:68:02
LPORT       : 10004
RHOST:PORT  : 192.168.56.1:10005
MTU:        : 1500

Also, let's make sure that there's connectivity between the users' hosts.

PC3> ping 192.168.10.2
84 bytes from 192.168.10.2 icmp_seq=1 ttl=63 time=18.002 ms
84 bytes from 192.168.10.2 icmp_seq=2 ttl=63 time=10.502 ms
84 bytes from 192.168.10.2 icmp_seq=3 ttl=63 time=13.502 ms
84 bytes from 192.168.10.2 icmp_seq=4 ttl=63 time=17.502 ms
84 bytes from 192.168.10.2 icmp_seq=5 ttl=63 time=22.503 ms
PC3> ping 192.168.20.2
84 bytes from 192.168.20.2 icmp_seq=1 ttl=63 time=10.501 ms
84 bytes from 192.168.20.2 icmp_seq=2 ttl=63 time=20.003 ms
84 bytes from 192.168.20.2 icmp_seq=3 ttl=63 time=14.502 ms
84 bytes from 192.168.20.2 icmp_seq=4 ttl=63 time=18.002 ms
84 bytes from 192.168.20.2 icmp_seq=5 ttl=63 time=16.002 ms

Bridge group on the router

Common Cisco routers (without an auxiliary switch module) can perform switching of Ethernet frames that arrive at the physical interfaces or sub-interfaces bundled into a bridge group. When it comes to their capabilities, such interfaces bound into a bridge group are quite similar to the interfaces of a common L2 or L3 switch.

Build the network which is presented on the image below. Use a Cisco 7200 series device as R1 router. IOU1 switch is a common IOS on Unix L2 switch that is connected to the network using Oracle Virtual Box.

Let's place PC1, PC2, and PC3 end users' hosts to 192.168.0.0/24 IP subnet. Switching will be performed between these hosts. PC4 host will be assigned 192.168.1.2/24 address (from another IP subnet). Routing with this host will be performed upon traffic exchange. As a matter of course, PC1 and PC2 hosts may be located in the same virtual local network. In this case, traffic forwarding between the two will be performed using IOU1. However, we will intentionally place them in different virtual local networks (VLAN 10 and VLAN 20) so that the commutation is performed by R1 router. A trunk, where the necessary virtual networks (VLAN 10 and VLAN 20) are transferred, should be configured between IOU1 and R1. Let's switch to the setting up.

Let's create necessary virtual networks on IOU1 and manage the interfaces the way it's shown below.

IOU1#sho vla bri
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Et0/3, Et1/0, Et1/1, Et1/2
 Et1/3, Et2/0, Et2/1, Et2/2
 Et2/3, Et3/0, Et3/1, Et3/2
 Et3/3
10   up                               active    Et0/1
20   down                             active    Et0/2
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
IOU1#sho run int e0/1
Building configuration...
Current configuration : 93 bytes
!
interface Ethernet0/1
 switchport access vlan 10
 switchport mode access
 duplex auto
end
IOU1#sho run int e0/2
Building configuration...
Current configuration : 93 bytes
!
interface Ethernet0/2
 switchport access vlan 20
 switchport mode access
 duplex auto
end
IOU1#sho run int e0/0
Building configuration...
Current configuration : 140 bytes
!
interface Ethernet0/0
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10,20
 switchport mode trunk
end
IOU1#sho int tru
Port        Mode             Encapsulation  Status        Native vlan
Et0/0       on               802.1q         trunking      1
Port        Vlans allowed on trunk
Et0/0       10,20
Port        Vlans allowed and active in management domain
Et0/0       10,20
Port        Vlans in spanning tree forwarding state and not pruned
Et0/0       10,20

Let's create two sub-interfaces, corresponding to the virtual local networks we created earlier, on Gi0/0 physical interface of R1 router.

R1#sho run int gi0/0
Building configuration...
Current configuration : 111 bytes
!
interface GigabitEthernet0/0
 no ip address
 duplex full
 speed 1000
 media-type gbic
 negotiation auto
end
R1#sho run int gi0/0.10
Building configuration...
Current configuration : 63 bytes
!
interface GigabitEthernet0/0.10
 encapsulation dot1Q 10
end
R1#sho run int gi0/0.20
Building configuration...
Current configuration : 63 bytes
!
interface GigabitEthernet0/0.20
 encapsulation dot1Q 20
end

Let's enable IRB (Integrated routing and bridging) support on R1, specify the used STP version, and bundle the three interfaces into a group.

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#bridge irb
R1(config)#bridge 1 protocol ieee
R1(config)#int gi0/0.10
R1(config-subif)#bridge-group 1
R1(config-subif)#int gi0/0.20
R1(config-subif)#bridge-group 1
R1(config-subif)#int fa1/0
R1(config-if)#bridge-group 1
R1(config-if)#^Z
R1#sho bridge 1 verbose
Total of 300 station blocks, 300 free
Codes: P - permanent, S - self
Flood ports (BG 1)           RX count    TX count
GigabitEthernet0/0.10               0           0
GigabitEthernet0/0.20               0           0
FastEthernet1/0                     0           0

Let's configure PC1, PC2, and PC3 hosts and check whether there's connectivity between them.

PC1> sho ip
NAME        : PC1[1]
IP/MASK     : 192.168.0.2/24
GATEWAY     : 192.168.0.1
DNS         :
MAC         : 00:50:79:66:68:00
LPORT       : 10001
RHOST:PORT  : 192.168.56.101:10001
MTU:        : 1500
PC2> sho ip
NAME        : PC2[1]
IP/MASK     : 192.168.0.3/24
GATEWAY     : 192.168.0.1
DNS         :
MAC         : 00:50:79:66:68:01
LPORT       : 10002
RHOST:PORT  : 192.168.56.101:10002
MTU:        : 1500
PC3> sho ip
NAME        : PC3[1]
IP/MASK     : 192.168.0.4/24
GATEWAY     : 192.168.0.1
DNS         :
MAC         : 00:50:79:66:68:03
LPORT       : 10004
RHOST:PORT  : 192.168.56.1:10003
MTU:        : 1500
PC1> ping 192.168.0.3
84 bytes from 192.168.0.3 icmp_seq=1 ttl=64 time=19.503 ms
84 bytes from 192.168.0.3 icmp_seq=2 ttl=64 time=19.502 ms
84 bytes from 192.168.0.3 icmp_seq=3 ttl=64 time=19.503 ms
84 bytes from 192.168.0.3 icmp_seq=4 ttl=64 time=19.502 ms
84 bytes from 192.168.0.3 icmp_seq=5 ttl=64 time=19.503 ms
PC1> ping 192.168.0.4
84 bytes from 192.168.0.4 icmp_seq=1 ttl=64 time=10.501 ms
84 bytes from 192.168.0.4 icmp_seq=2 ttl=64 time=19.503 ms
84 bytes from 192.168.0.4 icmp_seq=3 ttl=64 time=19.502 ms
84 bytes from 192.168.0.4 icmp_seq=4 ttl=64 time=19.503 ms
84 bytes from 192.168.0.4 icmp_seq=5 ttl=64 time=19.502 ms

Review network statistics for interfaces in the group as well as the bridge table on R1 router.

R1#sho bridge 1 verbose
Total of 300 station blocks, 297 free
Codes: P - permanent, S - self
BG Hash      Address      Action  Interface      VC    Age   RX count   TX count
 1 68/0   0050.7966.6800 forward  Gi0/0.10        -      0         17         17
 1 69/0   0050.7966.6801 forward  Gi0/0.20        -      0          6          5
 1 6B/0   0050.7966.6803 forward  FastEthernet1/0 -      0         11         10
Flood ports (BG 1)           RX count    TX count
GigabitEthernet0/0.10               0           0
GigabitEthernet0/0.20               0           0
FastEthernet1/0                     0           0

One should configure BVI virtual interface, the number of which must be equal to the number of the group we created earlier, in order to ensure that there's routing between the group's hosts and PC4 host. Also, one will need to configure Fa1/1 physical interface.

R1#sho run int BVI 1
Building configuration...
Current configuration : 60 bytes
!
interface BVI1
 ip address 192.168.0.1 255.255.255.0
end
R1#sho run int fa1/1
Building configuration...
Current configuration : 96 bytes
!
interface FastEthernet1/1
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
end
R1#sho ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
 + - replicated route, % - next hop override
Gateway of last resort is not set
 192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, BVI1
L        192.168.0.1/32 is directly connected, BVI1
 192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, FastEthernet1/1
L        192.168.1.1/32 is directly connected, FastEthernet1/1

Let's use bridge 1 route command to select the protocol where packet routing should be performed.

R1(config)#bridge 1 route ?
 clns    ISO CLNS
 decnet  DECnet
 ip      IP
 ipx     Novell IPX
R1(config)#bridge 1 route ip

Configure a PC4 user host. Make sure that there is connectivity between PC4 host and other user hosts.

PC4> sho ip
NAME        : PC4[1]
IP/MASK     : 192.168.1.2/24
GATEWAY     : 192.168.1.1
DNS         :
MAC         : 00:50:79:66:68:02
LPORT       : 10006
RHOST:PORT  : 192.168.56.1:10005
MTU:        : 1500
PC4> ping 192.168.0.2
84 bytes from 192.168.0.2 icmp_seq=1 ttl=63 time=18.502 ms
84 bytes from 192.168.0.2 icmp_seq=2 ttl=63 time=19.502 ms
84 bytes from 192.168.0.2 icmp_seq=3 ttl=63 time=19.503 ms
84 bytes from 192.168.0.2 icmp_seq=4 ttl=63 time=19.502 ms
84 bytes from 192.168.0.2 icmp_seq=5 ttl=63 time=49.506 ms
PC4> sho arp
ca:04:32:b8:00:1d  192.168.1.1 expires in 23 seconds
PC4> trace 192.168.0.2
trace to 192.168.0.2, 8 hops max, press Ctrl+C to stop
 1   192.168.1.1   8.501 ms  9.501 ms  9.501 ms
 2   *192.168.0.2   19.502 ms (ICMP type:3, code:3, Destination port unreachable)

Review the current status of STP on R1 router and IOU1 switch.

R1#sho spanning-tree 1 brief
Bridge group 1
 Spanning tree enabled protocol ieee
 Root ID    Priority    32768
 Address     ca04.32b8.001c
 This bridge is the root
 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
 Bridge ID  Priority    32768
 Address     ca04.32b8.001c
 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
 Aging Time 300
Interface                                   Designated
Name                 Port ID Prio Cost  Sts Cost  Bridge ID            Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet1/0      128.5    128    19 FWD     0 32768 ca04.32b8.001c 128.5
GigabitEthernet0/0.1 128.8    128     4 FWD     0 32768 ca04.32b8.001c 128.8
GigabitEthernet0/0.2 128.9    128     4 FWD     0 32768 ca04.32b8.001c 128.9
IOU1#sho spanning-tree vla 10
VLAN0010
 Spanning tree enabled protocol ieee
 Root ID    Priority    32768
 Address     ca04.32b8.001c
 Cost        100
 Port        1 (Ethernet0/0)
 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
 Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
 Address     aabb.cc00.0100
 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
 Aging Time  300 sec
Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Root FWD 100       128.1    Shr
Et0/1               Desg FWD 100       128.2    Shr
IOU1#sho spanning-tree vla 20
VLAN0020
 Spanning tree enabled protocol ieee
 Root ID    Priority    32768
 Address     ca04.32b8.001c
 Cost        100
 Port        1 (Ethernet0/0)
 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
 Bridge ID  Priority    32788  (priority 32768 sys-id-ext 20)
 Address     aabb.cc00.0100
 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
 Aging Time  15  sec
Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Root FWD 100       128.1    Shr
Et0/2               Desg FWD 100       128.3    Shr

Specify the bridge priority equal to 65000 on R1 router. Find out in what way the distribution of switches and ports roles changed from the point of view of STP. Please explain the changes that took place.

R1(config)#bridge 1 priority 65000
R1(config)#do sho span bri
Bridge group 1
 Spanning tree enabled protocol ieee
 Root ID    Priority    32778
 Address     aabb.cc00.0100
 Cost        4
 Port        8 (GigabitEthernet0/0.10)
 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
 Bridge ID  Priority    65000
 Address     ca04.32b8.001c
 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
 Aging Time 15
Interface                                   Designated
Name                 Port ID Prio Cost  Sts Cost  Bridge ID            Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet1/0      128.5    128    19 FWD     4 65000 ca04.32b8.001c 128.5
GigabitEthernet0/0.1 128.8    128     4 FWD     0 32778 aabb.cc00.0100 128.1
GigabitEthernet0/0.2 128.9    128     4 FWD     4 65000 ca04.32b8.001c 128.9

Perform capturing of the user and management traffic on the link between R1 router and IOU1 switch and meticulously analyze it using Wireshark.

Add comment


Security code
Refresh

Comments   

0 #1 Hybrid L2/L3 Devices Lablab controls 2017-01-16 21:28
Nicely put, Regards!
Quote | Report to administrator
Found a typo? Please select it and press Ctrl + Enter.